Your comments

I have never had so many plugin crashes and even SYSTEM crashes as with the current version of the software.  I now average better than 1 plugin crash a day (two in the past 30 minutes).  My system NEVER crashes except when Tanki is running.  If you're going to punish users with stupid updates like MatchMaker, why punish them even more with unstable software?

How is matchmaker supposed to be better than the old system?  I just waited over 6 minutes to get into a battle.  I never had to do that before - and I don't even have a choice of maps!

I've tried every "solution" that has been offered. But let's explore the list:

I was using Safari when the first fail occurred (about a month ago)

Customer "Service" (CS) said try Firefox.

Firefox failed.

CS - try Chrome

Chrome works - but graphics are terrible. (You can be picked apart by rails you cannot even see)

I tried the standalone Flash Client. It worked okay --- until about two days ago. Load times were long because it doesn't cache anything. Then it stopped working.

CS- The VLOG announced that the new Flash update fixed the problem. I installed the "new" update. The "new" update, turned out to be v.23, which is what broke things in the first place. The VLOG lied.

CS- recommended rolling back to v.22. I've done that. Twice. Each time, Tanki prevented me from using v.22. This is not, as you alluded, an Adobe Flash problem. It is a Tanki problem. The error message:

is NOT an Adobe Flash error message. It is a Tanki error message.


While the Mac does have protections to prevent the accidental use of out-of-date Flash plugins, those can be disabled. I have done that. The question here is why Tanki would recommend a roll-back to v.22, but then require v.23!??


I appreciate you do not work at Adobe. And I understand you are a volunteer. Neither of those excuse you from publishing incorrect, untested rumors of solutions. If you're going to represent Tanki, (and your moderator status says you do), you should at least check to make sure the information you're providing is sound. Sending people off to try things you "heard" isn't helpful. It just causes people to waste time and increases frustration.


I used the Tanki client last night. It worked okay. So at present, the only two options that appear to work are:


1) Chrome (but graphics are bad), and,

2) The Tanki client.

I rebooted Safari, but did NOT reboot the system. When I rebooted the SYSTEM, fired up Safari, went to Tanki on line with v.22 of the Flash Plugin, I got...



I don't know about Shoaib, so I'll wait and see. So far, I'm not aware any of my comments have been censored. But neither do I expect Tanki (based on past history) to take any corrective actions (though one might hope.)


As for "Trojans" - I'm not aware of any issues with that relating to Tanki. Flash has long been considered a security hole, but that's not Tanki's fault.

As for the client - wouldn't it make sense for Tanki to automatically pre-select the language choice based on the downloader's IP address? I mean, how many Russian language users do you think are in Dallas, Texas? And how many English language users are in Kiev? IP mapping takes milliseconds, and then you just download the properly pre-configured client.


The language selection issue is just ANOTHER example of how Tanki CREATES problems that never should have existed in the first place.


Too complicated for you? Or you just never even considered the customer?

Thanks for the clarification on that. Now... can you tell me why Tanki hasn't fixed it so v.22 just works? Because what "Customer Service" says is "roll back to v22" and when you do, it doesn't work. This is something that is 100% within Tanki control - they just need to set the version check at the front end to accept v.22 and the roll-back would work (assuming there's not some OTHER issue that would prevent that.) What you appear to be saying is Flash v.23 has problems, Flash v.22 works, roll back to v.22 - WHICH WON'T WORK BECAUSE TANKI BLOCKS IT.


The message I get is NOT an Apple-generated message. AFTER following your instructions, I get



Something tells me it's not my Mac that's generating that message IN RUSSIAN!


It's that last part that makes no sense whatsoever. Tanki should be detecting v.23 and warning users it does not work - and sending them to a web page with instructions on how to roll back to v.22. Instead, TANKI BLOCKS V.22!!!


On the plus side, this is a PERFECT example of how Tanki "Customer Service" works. It does nothing but waste time and give out "solutions" that do not work.

That does NOT work. It's what "Customer Service" will tell you - but it's not helpful. You can downgrade your Flash plug-in to v22 - but that doesn't work either because Tanki checks your Flash version and if it isn't v.23, it won't let you run.

Actually, it's my experience that Tanki is always there to PRETEND to help. I have never had a response from Tanki of any kind that actually helped anything. Tanki Customer Support is the worst I've ever seen from any company in any industry. Not only are responses unhelpful, they are sometimes also simply not true.

Yeah, that tells us how to downgrade the Flash plug-in. Problem is, since it's not the CURRENT VERSION Tanki won't let us use it! Tanki is blocking this solution!!!