Can't enter the game neither from client nor browser

ARCEUSARCER 4 years ago updated by Jdawg85 1 year ago 11 1 duplicate

This problem has been repeatedly coming after some months before this problem I could play

TankiOnline as normal then 1 day suddenly the loading bar gets stuck at the very near end

and the loading goes on forever (the problem was on both client and browser).

Then some months later i checked my account and it opened up again like the problem had disappeared

(it was possible for me after i updated and downloaded flash player over and over for days)

.....But now again the same issue exists i have been not able to play TankiOnline several weeks now please help... my Adobe Flash player is latest (25.0.0148) and i have windows 8.1 as an operating system with Intel Pentium graphic card please help I have missed the Cosmonautics Day Celebrations too!!!(i guess)


Whenever I try to enter the game ,sometimes the screen is just grey or it say install flash player (Whereas i have the latest version)


After the last day I had played tanki on the client the very next day its loading too got stuck at the end and when i uninstalled it and tried to reinstall from tanki website (www.tankionline.com/en/) but after it gets downloaded and i run it , it says the version is not compatible with my PC....(And i have tried doing this again and again even when i was writing this message to you but its of no use..)

In the below pic if i click run anyway it says that this app can't run on my PC and find another version of the app..

Please help it would be great playing tanki again....

Duplicates 1


Regarding your browser:

When the loading bar stays forever that usually means you need to clear your cache . Read how to do so HERE.

If your browser says you need to install Flash its likely you have installed the incorrect version for your browser. Click THIS link to install the correct version. If this doesn't fix the issue try downloading Google Chrome to play.

Regarding the client:

Please send a screen of the message that comes AFTER you click 'run anyway'.

Same problem with google chrome too i cleared all possible amount of web cache but no change

I use this link to download flash : https://get.adobe.com/flashplayer/ (I have rechecked my version of flash player on it's site)

Here is the screenshot you requested..

I hope you got any solution for this and i would prefer to play tanki on client rather than on a browser

I hope you got any solution for this and i would prefer to play tanki on client rather than on a browser


Could you please give more information about your computer.

Is it 32bit or 64bit?

Did the client work before? If so, were any changes made to the computer, updates etc?

Can you install other software?

Well got some great news my tanki client opened up again today when i downloaded it from google chrome...thanks for your support...but the browser is still stuck on loading but anyways i am happy!

And please suggest how to counter this problem if it appears again in future.....


The only thing I can suggest is for you to check you hard drive space, all your issues point to it being full.

Thanks for the gift, i appreciate it!

Well great thanks to you!

For resolving this problem so fast rather than me not being able to play tanki for like months

Well got this problem again ... : /

Tried using Google Chrome but no the problem keeps on occurring..cleared all the cache in Firefox too but the loading bar is stuck at the end ...I have the latest version of Flash ( and have tried to reinstall the client but it says : Windows Protected Your PC

             running this app might put your PC at risk and if I click on run anyway it says this app can't run on my PC and check with the software publisher.. Please help.

And my hard disk is not full yet

Hey Arceusarcer, i am having these same issues now with client...was working fine for months and overnight now it just doesnt load properly. So frustrating. Was wondering if you ever found a fix? Thanks