+2
Answered

sticky keys

HisKingdomCome 1 year ago • updated by RubbenHub 9 months ago 3

I have been playing tanki for a few years (primarily on a different account) and know all the controls and settings very well. However, the last 2-3 months, the controls seem quite "sticky" in that my tank will keep going forward if I press the up arrow for quite some time after I release it. It's not just the up arrow, but all the controls. The movements of my tank are exaggerated or extended and it feels sometimes like there is a "Ghost" controller. What can I do? I know it's not my keyboard or computer as they are both just 7 months old and have a great processor--far better than what I played on before. I also have only been having this problem the last 4 months or so. Sometimes I feel like Tanki hacked my computer as the game also auto-loads when I restart my computer. Kind of pisses me off, honestly. I love the game and want to be able to control my tank the way I used to, but if it doesn't change, I'm just going to stop playing altogether. I've already cut back from 7-15 hours a week (sometimes 30-40hours), to about 1 hour a week. Please help.

Answer

Answer

Your controls problem is quite related to lag, a slow internet connection might be the cause. Try closing all your applications which use internet or connect via an ethernet cable. If everything is correct with your internet and the problem is still the same, clear the cache of the software you use to run the game. You can also try to change your controls to the ones you prefer in the settings.

As for the auto loading, follow the procedures below.

  1. Press Win-r . In the "Open:" field, type msconfig and press Enter .
  2. Click the Startup tab.
  3. Uncheck the items you do not want to launch on startup.
  4. When you have finished making your selections, click OK.
  5. In the box that appears, click Restart to restart your computer.
Answer

Your controls problem is quite related to lag, a slow internet connection might be the cause. Try closing all your applications which use internet or connect via an ethernet cable. If everything is correct with your internet and the problem is still the same, clear the cache of the software you use to run the game. You can also try to change your controls to the ones you prefer in the settings.

As for the auto loading, follow the procedures below.

  1. Press Win-r . In the "Open:" field, type msconfig and press Enter .
  2. Click the Startup tab.
  3. Uncheck the items you do not want to launch on startup.
  4. When you have finished making your selections, click OK.
  5. In the box that appears, click Restart to restart your computer.

I am having the same problem, I haven't played tanki in a long time and now that I have returned I have sticky keys, sometimes worse sometimes better, but it does make quite an annoyance. I have a relatively high end PC and 200MBPS down and 10MBPS Up with a Ping of 10ms. It is highly unlikely that that is the problem.