Please provide a screenshot of your supplies in the garage.

So should i take a screen shot of the supplies in the game or the supplies in the garage?

Everything seems fine. You can activate supplies by pressing 1, 2, 3, 4 or 5.

I know that but what i am saying is that for example, if i buy 100 mines and i pay 100 crystals for it, when i go back into battle i still have the same amount of mines as before but i still payed 100 crystals, thats the problem i am having

Answer
Answered

I see, in that case, please report to the Tech Support using this form.
I lost crystals/exp/items from my account

but the form is asking how many crystals i lost and when it happened but this is a frequent problem that keeps happening and i am sure than no one has my password because i start playing right after i buy the supplies which dod not show up in the game

Just put the amount of crystals spent on those supplies and provide more details(like number of supplies purchased, etc) in the big box below.

but what should i put in for the date, this is a thing that keeps happening, it not something that only happened once

Answered

Just put the latest one in the respective field. And you can explain the problem in detail in the explanation field.

i trird to do this but they sent back saying that there is no probem but this problem still occurs for me

I suggest you record short video of the problem and send it to tech support as a proof.

where could i find the tech support or could i just send it to you

I've same problem, few months ago I purchased repair kit ecc but when i go to battle the supplies does not show up. Why?