+11
Answered

Why am I getting plug-in failures?

Weedwacker2000 2 years ago • updated by JPTank616 2 years ago 66 16 duplicates

I played Tanki without any problems until a few hours ago. Every time I tried to join a match, it says "Plug-In Failure'. I only experience this problem when trying to play Tanki, every other site works fine. Why is this suddenly happening? I want to know WHY I'm getting plug-in failures.

Answer

Answer
Answered

Cause

While it is always recommended using the latest version of Flash Player, sometimes problems are encountered in a new release that were not present in a previous release. If you are unable to work around these problems and they block functionality you rely on, rolling back to a previous version might be required until an update is made available.


Solution

Follow the procedure below to roll back to previous version of flash player.

  1. Uninstall the current version of Flash Player. Here are the instructions.
  2. Download Flash Player 22.0.0.209 package (313 MB).
  3. Extract the zip package.
  4. Open folder named "22_0_r0_209" and run "flashplayer22_0r0_209_mac.dmg". (You will need to close all the browsers to continue installation)
  5. After the installation is complete, open Tanki Online in Safari. If you see this button , follow the guide here to load Flash Player content without updating it.
  6. Don't update the Flash Player to version 23.0.0.162.

Here is a video guide:

Enjoy the game! :)

Duplicates 16

yeah same happening to me, overtime i join a battle it exits me out and says plug-in failure

I would love to know the answer to this. I've read online on how to fix it, however those ways risk the safety of my computer. I don't want to take down my defenses. Plus I actually to know WHY I'm getting plug-in failures, I didn't ask how to fix it. However a way to fix it wouldn't hurt to know.

-1

The same thing started happening to me. Who do I fix that problem?

+1

i have the same problem since this afternoon...its frustrating cause i can't play now..plzz give me the solution

Ha, me too, same issue anyway to fix it????

same thing happened here. i updated the Adobe player flasher before. tried several tricks but problem persisted.

Have you tried Standalone flash player for Mac or chrome browser?
What is Standalone Flash Player?

+1

it does not work at all plz help find a solution to this! QwQ *cries* i love this game so much


same issue here too. I cleared my browser history and updated everything on my Mac. It was working fine 48 hours ago, and today I keep getting the Plug-in Failure too. What's up??? I love this game....missing it tonight sucks.

Did anyone tried Shoaib answer to the problem. The Standalone Flash player?

Yes, see my comment above about Standalone flash player

Yes. It worked great!.... until yesterday. Now it doesn't work at all.

can you people of tank online fix this PLUG IN FAILURE ITS FRIDAY AND I WANT TO PLAY I LOVE THIS GAME WHY?!?!?!?!? fix this plz and put the anwser here TWT

+1

Really, no fix for plug-in failure!

  1. I used the Standalone Flash player to ease last nights frustrations. It works, and you can play. But the graphics are awful, rough and underdeveloped for this day and age. It sucks. Too bad this is on Tanki's end and they can't get it to fix, because I'm sure there are other players aggravated over this nonsense who haven't spoken up. I mean out of nowhere, there had to be some sort of tweak that occurred, and we're screwed. Try the Standalone, but expect low quality graphics and other issues we used to have ages ago on some of Tanki's upgrades- like "turn off all backgrounds, chat, etc so it-can-work stuff" FPS warning. Come on Tanki I love the game, so please find the plug-in issue and fix it.
+1

Seems like it all started about 3 days ago. What did you do Tanki??

-1

Found out about using Google Chrome with a Mac. It works! Safari as you know isn't doing it. Playing like it should. Use Chrome.

Chrome works. Graphics suck. Chrome is the last option. Safari, Firefox don't work. Standalone Flash Player doesn't work. Flash plugin downgrades don't work (Tanki prevents them from working!!) The client might work - but it's all in Russian and you can't even figure out which game is what - so if you're working on missions - forget it. And it crashed.

+1

plz answer tank online i can't play the game and i love it !

+1

it's been on for like 3 days.Why ?

plz fix the problem tank online i want to play the game

same every time i try joining a match it glitches and then it says: plug in failure . please fix this

Plug-in failure for me me too despite downloading and updating Adobe Flash Player and the latest version of my browser. I don't understand why Tanki needs 'updating' all the time. Looks like it's because they are just greedy and want more and more money. If a game isn't broken it doesn't need fixing! Now Tanki has updated the game so much it is broken and they can't be bothered to fix it!

+1

yeah but that is annoying.why don't they fix it ?

is everyone having the same problem ?

Yeah we all have the same problem. I think we need to put $ dollar signs in our posts as that is the only thing that will interest the Tanki staff!

press the vote button at the top of the page maybe it will the people notice the problem and fix it

had some problem, dunno how 2 fix.

Roll back the flash player to version 22.0, restart the system and try to run the game. Also try standalone flash player.

I have the same problem also

UgNitz here. Tried re-intalling flash plugin and using standalone etc. Game is dead for now for me too. That's what we get for playing a game that’s run and administered by Ru . ;)


LoL. I wrote ha><ors and the admin deleted it! Hahaha. That’s kinda cute actually :)

Also got the same problems after updating the latest adobe flash player. Until this is sorted I simply will not play ...... shame ... I quite enjoyed the game.

Google Chrome is he solution!!!!! It works!!!

press the vote button on the top it will make the tank online crew notice the problem and maybe fix it

they are doing a server update maybe it will help the problem

Hey, it’s true, Google Chrome works for some reason, though Safari and Firefox don’t. :-)


Same problem, it's been a 4-5 days that I just can't play

Answer
Answered

Cause

While it is always recommended using the latest version of Flash Player, sometimes problems are encountered in a new release that were not present in a previous release. If you are unable to work around these problems and they block functionality you rely on, rolling back to a previous version might be required until an update is made available.


Solution

Follow the procedure below to roll back to previous version of flash player.

  1. Uninstall the current version of Flash Player. Here are the instructions.
  2. Download Flash Player 22.0.0.209 package (313 MB).
  3. Extract the zip package.
  4. Open folder named "22_0_r0_209" and run "flashplayer22_0r0_209_mac.dmg". (You will need to close all the browsers to continue installation)
  5. After the installation is complete, open Tanki Online in Safari. If you see this button , follow the guide here to load Flash Player content without updating it.
  6. Don't update the Flash Player to version 23.0.0.162.

Here is a video guide:

Enjoy the game! :)

Yeah, that tells us how to downgrade the Flash plug-in. Problem is, since it's not the CURRENT VERSION Tanki won't let us use it! Tanki is blocking this solution!!!

yeah google chrome works but it's weird that safari doesn't .Try google chrome it works for sure

-2

I forgot to add! Since I tried Google Chrome my Russian spam emails have shot up by over 1000%! Used to get the odd message requesting marriage now it's 5 or 6 messages an hour and lots of other links in Russian! This is the only game I play from Russia and the only Russian website I have ever visited and since I started using Google Chrome to play it the email traffic from Russia has gone up massively! Why is that Tanki?

-1

You can unsubscribe them. If you see ads, read the following article:

Ads not from this site?

-1

I can't believe Tanki has censored and removed a message stating that Google Chorme access user details! Russian censorship applies in Russia as you haven't got freedom of speech but obviously freedom of speech doesn't apply here too on Tanki! All my comments are from my own personal experiences which I can state in a clear and concise way! Nothing is rude or offensive and stop censoring my comments Tanki! In Russia you can't speak the truth but in the UK and the rest of Europe we can!

-1

If you just explain your problem in a calm way by taking a positive approach, we are always here to help.

-1

[Removed] Google Chrome now only works on Tanki whilst Safari and Firefox doesn't. Google access user details through Google Chrome for various nefarious reasons. Google can access users webcams when using Google Chrome and is another reason to avoid using Google Chrome. Perfectly 'calm' and perfectly truthful but no doubt will be censored by you or Tanki as it is something you do not want players to know. Thank you!

Actually, it's my experience that Tanki is always there to PRETEND to help. I have never had a response from Tanki of any kind that actually helped anything. Tanki Customer Support is the worst I've ever seen from any company in any industry. Not only are responses unhelpful, they are sometimes also simply not true.

wait, how do you get google chrome?

-1

If you want to play on Google Chrome, you can download it from here.

Same thing is happening to me for 3 weeks now, shockwave crash every time. I'm about ready to quit trying to play!

-1

Update your Adobe Flash Player to latest version.

+1

That does NOT work. It's what "Customer Service" will tell you - but it's not helpful. You can downgrade your Flash plug-in to v22 - but that doesn't work either because Tanki checks your Flash version and if it isn't v.23, it won't let you run.

+2

This is one of those serious problems for which Tanki Customer "Service" seems to have an endless supply of "solutions" THAT DO NOT WORK.


I used to play Tanki on Safari. Then the Flash problem cropped up. Upgrade to the latest plug-in, I was told. That didn't fix it. I was told to try Firefox. Same issue. Then told to try the Tanki client. That was before there WAS a Mac client, so obviously THAT didn't work. Then I was told to use the LAST version of the Flash client - they even gave me a download link. So I installed that. You can probably guess what happened... TANKI WOULDN'T LET ME USE THAT VERSION OF THE PLUG-IN BECAUSE IT WAS "OUT OF DATE". What SHOAIB.ZAFAR says is probably a solution, except Tanki wouldn't let it BE a solution! Tanki was requiring (probably still is) v.23. The last version that worked was v.22.


So That didn't work.

I tried Chrome - which works... but the graphics quality is HORRIBLE.


Then the VLOG declared that there was a Flash problem with the Mac plug-in (took them over a week to figure that out??), but the latest version of the plug=in would fix it.


The VLOG LIED! The latest Flash plugin was the same one I started out with.


Then I was told the Mac Client was out - and it is - but it's in Russian and it crashes!


I gave up on all the other choices that didn't work (and Chrome with its crappy graphics) and just used the Standalone Flash Player - which worked great (except it doesn't cache anything, so startup is painful) - but it stopped working tonight. So I sent in an email explaining the problem - and they sent me to this page, which clearly does not have any solutions.


If you're on a Mac, Chrome is the only solution I know of that (sort of) works. The graphics make it hard to play - but it will work - sort of.


All the other "solutions" appear to be dead - at least until Tanki pulls its collective head out and allows users to roll back and use Flash plugin v.22.


And Customer Service? If you didn't already know it, they're nothing but a huge waste of time. Just stop playing Tanki. And don't send them a dime for anything until they get a real Customer Service department.

-1

Hi there!

I clearly mentioned the solution for that issue too. Please read the point.5 carefully.

After the installation is complete, open Tanki Online in Safari. If you see this button , follow the guide here to load Flash Player content without updating it.

By the way, you can change the language of official game client. Just follow this.

+2

Thanks for the clarification on that. Now... can you tell me why Tanki hasn't fixed it so v.22 just works? Because what "Customer Service" says is "roll back to v22" and when you do, it doesn't work. This is something that is 100% within Tanki control - they just need to set the version check at the front end to accept v.22 and the roll-back would work (assuming there's not some OTHER issue that would prevent that.) What you appear to be saying is Flash v.23 has problems, Flash v.22 works, roll back to v.22 - WHICH WON'T WORK BECAUSE TANKI BLOCKS IT.


The message I get is NOT an Apple-generated message. AFTER following your instructions, I get



Something tells me it's not my Mac that's generating that message IN RUSSIAN!


It's that last part that makes no sense whatsoever. Tanki should be detecting v.23 and warning users it does not work - and sending them to a web page with instructions on how to roll back to v.22. Instead, TANKI BLOCKS V.22!!!


On the plus side, this is a PERFECT example of how Tanki "Customer Service" works. It does nothing but waste time and give out "solutions" that do not work.

+1

I don't know about Shoaib, so I'll wait and see. So far, I'm not aware any of my comments have been censored. But neither do I expect Tanki (based on past history) to take any corrective actions (though one might hope.)


As for "Trojans" - I'm not aware of any issues with that relating to Tanki. Flash has long been considered a security hole, but that's not Tanki's fault.

Did you reboot your system after installing the version 22.0? That also happens when the the Flash Player is not installed or there is some malfunction during installation. If you are sure that the installation was successful, please restart your system once and try loading the Flash content. Please do that and let me know if it helps.
And from what I've heard, the bug has been fixed by Adobe. So the issue would no longer be there with ver 23.0.

+1

I rebooted Safari, but did NOT reboot the system. When I rebooted the SYSTEM, fired up Safari, went to Tanki on line with v.22 of the Flash Plugin, I got...



First of all, let me make one thing clear. The solution has been tested before it is posted here. And it worked for most of the players. You can't say that the solution is incorrect or not tested just because it didn't work for you. Secondly, I don't work at Adobe. I am volunteer to help players solve their technical issues.


As you know Tanki Online is based on Flash Player. And after the release of ver 23.0, Mac users weren't able to load most of the Flash content on Safari and Opera browsers.


By the way, have you tested the official game client or standalone flash player? If so, did you experience any problems with those platforms?

+1

I've tried every "solution" that has been offered. But let's explore the list:

I was using Safari when the first fail occurred (about a month ago)

Customer "Service" (CS) said try Firefox.

Firefox failed.

CS - try Chrome

Chrome works - but graphics are terrible. (You can be picked apart by rails you cannot even see)

I tried the standalone Flash Client. It worked okay --- until about two days ago. Load times were long because it doesn't cache anything. Then it stopped working.

CS- The VLOG announced that the new Flash update fixed the problem. I installed the "new" update. The "new" update, turned out to be v.23, which is what broke things in the first place. The VLOG lied.

CS- recommended rolling back to v.22. I've done that. Twice. Each time, Tanki prevented me from using v.22. This is not, as you alluded, an Adobe Flash problem. It is a Tanki problem. The error message:

is NOT an Adobe Flash error message. It is a Tanki error message.


While the Mac does have protections to prevent the accidental use of out-of-date Flash plugins, those can be disabled. I have done that. The question here is why Tanki would recommend a roll-back to v.22, but then require v.23!??


I appreciate you do not work at Adobe. And I understand you are a volunteer. Neither of those excuse you from publishing incorrect, untested rumors of solutions. If you're going to represent Tanki, (and your moderator status says you do), you should at least check to make sure the information you're providing is sound. Sending people off to try things you "heard" isn't helpful. It just causes people to waste time and increases frustration.


I used the Tanki client last night. It worked okay. So at present, the only two options that appear to work are:


1) Chrome (but graphics are bad), and,

2) The Tanki client.

Again, as I said earlier, the solution is tested and worked successfully for many Mac users before it was posted here.

By the way, Tanki Client is good, except that there is no refresh option. I always recommend Standalone Flash Player, but from a few days it is not storing any map cache. If it's not even opening the server, try the solution here. And again, it is tested.

+1

As for the client - wouldn't it make sense for Tanki to automatically pre-select the language choice based on the downloader's IP address? I mean, how many Russian language users do you think are in Dallas, Texas? And how many English language users are in Kiev? IP mapping takes milliseconds, and then you just download the properly pre-configured client.


The language selection issue is just ANOTHER example of how Tanki CREATES problems that never should have existed in the first place.


Too complicated for you? Or you just never even considered the customer?

Shoaib removed all my comments that I made yesterday which explained how bad he is as a moderator and how poor customer service is with Tanki. All true comments but Shoaib and Tanki don't like the truth. Shoaib you need to change profession as you are no good as a moderator and you do not help anyone here and you should go! Remove my comments again but you know the truth and even though you keep on censoring me you cannot run from the the truth!

I've given up playing Tanki now and it's a shame as it used to be a good game!